Bleepingcomputer Critical vm2 Vulnerability Allows Arbitrary Code Execution on Host Systems
Article Content
- •CVE-2026-26956 allows arbitrary code execution on host systems running vulnerable vm2 versions.
- •The vulnerability affects environments with Node.js 25 and WebAssembly exception handling enabled.
- •Users should upgrade to vm2 version 3.10.5 or later to mitigate exploitation risks.
A critical vulnerability (CVE-2026-26956) in the vm2 Node.js sandboxing library enables attackers to escape the sandbox and execute arbitrary code on host systems. This flaw affects vm2 version 3.10.4 and earlier, particularly in environments running Node.js 25 with WebAssembly exception handling enabled. The vulnerability arises from improper handling of exceptions crossing between the sandbox and the host, allowing attackers to access sensitive Node.js internals. Users are urged to upgrade to vm2 version 3.10.5 or later to mitigate risks. This incident is part of a series of vulnerabilities affecting vm2, highlighting ongoing challenges in securely isolating untrusted code. The library is widely used, with over 1.3 million weekly downloads, impacting numerous applications relying on it for executing user-supplied scripts.
Ask AI about this cluster
Answers cite the sources they use
Timeline
More articles in this cluster (13)
Following this threat?
Track CVE-2022-36067 in your own feed — you're alerted when they show up in new reporting, leak sites or exploitation.
Free account · no card needed
Continue Reading
Critical BeyondTrust 9.3 Vulnerability Actively Exploited by Threat Actor A critical vulnerability (CVE-2026-102764) in BeyondTrust Remote Support has been discovered and is actively being exploited by the threat group ARMORY CASTLE, reportedly linked to China. The vulnerability, which has a CVSS score of 9.3, allows unauthenticated attackers to upload files and potentially compromise host…