CVE-2026-123545: CSRF Vulnerability in OpenIdentityPlatform's OAuth 2.0 Flow
Article Content
- •CVE-2026-123545 affects OpenAM versions 14.5.1 to 16.1.3.
- •Attackers can exploit this CSRF vulnerability to obtain user tokens without consent.
- •Upgrade to OpenAM 16.1.4 is necessary to mitigate this risk.
OpenAM versions 14.5.1 to 16.1.3 are affected by a cross-site request forgery (CSRF) vulnerability in the OAuth 2.0 device authorization flow. This flaw allows attackers to approve device codes without user consent, potentially compromising user accounts. Attackers can lure logged-in users to malicious pages, gaining access and ID tokens to call APIs as that user. The vulnerability is particularly concerning for organizations using implied-consent clients that allow consent to be skipped. OpenAM 16.1.4 addresses this issue by requiring explicit user actions for device code approvals. As of now, there is no evidence of active exploitation, but the risk remains high due to the potential for account compromise. Organizations are advised to upgrade to the fixed version and review their configurations to mitigate risks.
Ask AI about this cluster
Answers cite the sources they use
Timeline
More articles in this cluster (3)
Following this threat?
Track CVE-2026-123545 in your own feed — you're alerted when they show up in new reporting, leak sites or exploitation.
Free account · no card needed
Common questions
Which versions of OpenAM are affected?
What should organizations do to protect themselves?
Is there any evidence of active exploitation?
Continue Reading
CVE-2026-121451: High-Risk CSRF Vulnerability in AB Download Manager AB Download Manager versions prior to 1.11.2 have a cross-site request forgery (CSRF) vulnerability. This flaw allows remote attackers to write files to arbitrary paths via an unauthenticated browser-integration API. A malicious web page can exploit this by sending a crafted request to the /start-headless-download…
Critical RCE Vulnerability in Prefab UI Disclosed A critical remote code execution vulnerability, CVE-2026-120338, was disclosed on November 1, 2026, affecting Prefab UI's Generative UI sandbox. The flaw allows attackers to execute arbitrary Python code by exploiting Deno's permissions, enabling file read/write access on the host server. This vulnerability affects…