Skip to content
Critical RCE Vulnerability in Prefab UI Disclosed

Critical RCE Vulnerability in Prefab UI Disclosed

First seen 2 Nov 2026, 05:46 UTC • •

Article Content

Browse articles
ThreatCluster AI
ThreatCluster •November 2, 2026 at 07:19 UTC
  • •CVE-2026-120338 has a CVSS score of 10.0, indicating critical severity.
  • •The vulnerability allows remote code execution via Deno's permission bypass.
  • •A patch was released in version 0.21.0 to mitigate the vulnerability.

A critical remote code execution vulnerability, CVE-2026-120338, was disclosed on November 1, 2026, affecting Prefab UI's Generative UI sandbox. The flaw allows attackers to execute arbitrary Python code by exploiting Deno's permissions, enabling file read/write access on the host server. This vulnerability affects versions 0.14.0 to 0.20.2, with a CVSS score of 10.0, indicating critical severity. The issue arises when the sandbox runs untrusted code without adequate restrictions, particularly on FastMCP servers lacking authentication. A patch was released in version 0.21.0, which revokes Deno permissions before accepting code, mitigating the risk. Organizations are urged to update to the latest version immediately to prevent exploitation. No public exploit code has been confirmed at this time.

Start a free Starter trial for enhanced analysis

Ask AI about this cluster

Updated just now How this analysis works

Timeline

2026-10-26
Patch released
Prefab UI version 0.21.0 was released, fixing the RCE vulnerability by revoking Deno permissions.
Research.Jfrog
2026-11-01
CVE-2026-120338 published
Prefab UI's critical RCE vulnerability disclosed, affecting versions 0.14.0 to 0.20.2.
Thehackerwire

More articles in this cluster (8)

Following this threat?

Track CVE-2026-120338 in your own feed — you're alerted when they show up in new reporting, leak sites or exploitation.

Free account · no card needed

Common questions

Which versions of Prefab UI are affected?
Versions 0.14.0 through 0.20.2 of Prefab UI are affected by CVE-2026-120338.
What is the severity of this vulnerability?
CVE-2026-120338 has a CVSS score of 10.0, indicating it is critical.
What should organizations do to mitigate this vulnerability?
Organizations should upgrade to Prefab UI version 0.21.0 or later to mitigate the risk.