Skip to content
Critical GitLab Vulnerability CVE-2026-110264 Disclosed

Critical GitLab Vulnerability CVE-2026-110264 Disclosed

First seen 27 Oct 2026, 02:13 UTC • •

Article Content

Browse articles
ThreatCluster AI
ThreatCluster •October 27, 2026 at 10:43 UTC
  • •CVE-2026-110264 is a critical vulnerability with a CVSS score of 10.
  • •Affected versions include GitLab CE and EE from 7.0 to 18.11.12.
  • •Patches are available in versions 18.11.13 and 19.0.10 and later.

A critical vulnerability (CVE-2026-110264) affecting GitLab Community and Enterprise Editions allows unauthenticated remote attackers to execute arbitrary code on vulnerable servers. The flaw, an integer overflow in the regular-expression compiler, impacts all versions from 7.0 to 18.11.12. GitLab has released patches in versions 18.11.13 and 19.0.10 and later. Users are urged to upgrade immediately to mitigate the risk. The vulnerability was published on October 22, 2026, with a proof-of-concept available from October 23. The Cyber Centre has also issued an advisory regarding the critical patch release. Administrators should prioritize applying the updates to protect their systems from potential exploitation.

Start a free Starter trial for enhanced analysis

Ask AI about this cluster

Updated just now How this analysis works

Timeline

2026-10-21
GitLab security advisory issued
GitLab announced critical patches in versions 18.11.13 and 19.0.10 and later to address the vulnerability.
www.cyber.gc.ca
2026-10-22
CVE-2026-110264 published
GitLab disclosed a critical integer overflow vulnerability affecting multiple versions of GitLab CE and EE.
Yorku.Ca
2026-10-23
First public PoC released
Proof-of-concept code for CVE-2026-110264 became publicly available, increasing the risk of exploitation.
Yorku.Ca

More articles in this cluster (2)

Following this threat?

Track CVE-2026-110264 in your own feed — you're alerted when they show up in new reporting, leak sites or exploitation.

Free account · no card needed

Common questions

Which versions of GitLab are affected?
All versions from 7.0 to 18.11.12 of GitLab CE and EE are affected.
What should I do to protect my systems?
Upgrade to GitLab versions 18.11.13 or 19.0.10 and later as soon as possible.
Is there a known exploit in the wild?
While a proof-of-concept exists, there are no confirmed reports of active exploitation in the wild.