causalsecurity.com Critical Vulnerabilities Found in EPICS Base Control Software
Article Content
- •Four critical vulnerabilities in EPICS Base disclosed by CISA on October 27, 2026.
- •CVE-2026-114595 has a CVSS score of 9.8, allowing potential remote code execution.
- •No public exploitation has been reported; users should update to version 7.0.11.
Four vulnerabilities in EPICS Base, crucial for control systems in scientific facilities, were disclosed by CISA on October 27, 2026. The flaws, affecting versions 7.0.10 and earlier, could allow attackers to crash processes or potentially execute code remotely. The most severe vulnerability, CVE-2026-114595, has a CVSS score of 9.8 and involves an integer overflow that can lead to memory corruption. Other vulnerabilities include CVE-2026-114596 (8.2), CVE-2026-114597 (7.5), and CVE-2026-114598 (7.5), all related to network communication protocols. These vulnerabilities can be exploited without authentication, requiring only network access to vulnerable EPICS services. Causal Security's Cipher system discovered the flaws in under four hours, and no public exploitation has been reported so far. Users are urged to update to EPICS Base version 7.0.11 to mitigate risks.
Ask AI about this cluster
Answers cite the sources they use
Timeline
More articles in this cluster (4)
Following this threat?
Track CVE-2026-114595 in your own feed — you're alerted when they show up in new reporting, leak sites or exploitation.
Free account · no card needed
Common questions
Which versions of EPICS Base are affected?
What should I do to protect my systems?
Have these vulnerabilities been exploited in the wild?
Continue Reading
China-linked Hackers Exploit PHP2Shell to Compromise 25 Firewalls A China-linked threat actor has exploited vulnerabilities in PHP2Shell (CVE-2026-109618, CVE-2026-109619) and the Fragnesia privilege escalation bug (CVE-2026-46300) to gain root access to 25 firewalls, including those in an U.S. The attackers identified vulnerable systems using the FOFA search engine and executed…
Brotli Decoder Vulnerability Patched Across Multiple Linux Distributions A vulnerability, CVE-2026-111497, affecting the Brotli decoder has been patched in various Linux distributions, including Fedora 44 and Oracle Linux 10. The flaw allows for an out-of-bounds write, which could potentially enable attackers to execute arbitrary code. The vulnerability was published on October 22, 2026…