High Severity XSS Vulnerability in airMAX M Devices Disclosed
Article Content
- •CVE-2026-116836 is a high severity XSS vulnerability with a CVSS score of 8.8.
- •Unauthenticated attackers on adjacent networks can exploit this flaw to escalate privileges.
- •A patch is available; users must update to firmware version 6.3.26 or later.
On October 27, 2026, CVE-2026-116836 was published, revealing a Stored Cross-Site Scripting (XSS) vulnerability in airMAX M devices. This flaw allows unauthenticated attackers on adjacent networks to escalate privileges under certain conditions. The vulnerability has a CVSS score of 8.8, indicating high severity, and poses risks to device confidentiality, integrity, and availability. Currently, there is no public proof-of-concept or confirmed exploitation reported. A patch is available, and users are urged to update their firmware to version 6.3.26 or later. Security measures include restricting network access and monitoring for suspicious activity. The vulnerability was disclosed by multiple sources on the same day.
Ask AI about this cluster
Answers cite the sources they use
Timeline
More articles in this cluster (6)
Following this threat?
Track CVE-2026-116836 in your own feed — you're alerted when they show up in new reporting, leak sites or exploitation.
Free account · no card needed
Common questions
What devices are affected?
Is there any evidence of exploitation?
What should organizations do to protect themselves?
Continue Reading
Multiple WordPress Plugins Face Vulnerabilities Requiring Immediate Updates Three WordPress plugins have been reported with vulnerabilities: the GiveWP plugin (version 4.16.9) has a Cross Site Scripting (XSS) vulnerability, while both the Siteskite (version 2.1.8) and Cartflows (version 3.2.0) plugins have Remote Code Execution (RCE) vulnerabilities. The XSS vulnerability allows attackers to…