Multiple Semantic MediaWiki Versions Expose Authorization Flaws
Article Content
Browse articles
- •Semantic MediaWiki versions 2.5.0 to 7.3.0 have critical authorization flaws.
- •The vulnerabilities allow unauthorized access via specific API methods.
- •Immediate updates to version 7.3.1 or later are recommended to mitigate risks.
Semantic MediaWiki versions 2.5.0, 3.0.0, and 7.3.0 are affected by authorization vulnerabilities. The flaws allow unauthorized access through the smwtask API and isEditProtected methods, impacting all versions from 2.5.0 to 7.3.0. The vulnerabilities are categorized under CWE-862 for missing authorization. The affected systems include Semantic MediaWiki installations prior to version 7.3.1. Current advisories recommend immediate updates to mitigate risks. GitHub Security Advisories have documented these vulnerabilities, with CVEs GHSA-rjqv-6r83-pg8v and GHSA-9824-67pm-c29j noted. No has been reported yet, but the potential for abuse exists.
Ask AI about this cluster
Answers cite the sources they use
Updated just now How this analysis works
Timeline
2026-10-27
Vulnerabilities disclosed
Semantic MediaWiki vulnerabilities affecting versions 2.5.0 to 7.3.0 were disclosed, highlighting missing authorization issues.
VulnCheck2026-10-27
Advisories published
GitHub Security Advisories published details on the vulnerabilities, including CVE identifiers for tracking.
VulnCheck2026-10-27
Patch recommended
Users are urged to upgrade to Semantic MediaWiki version 7.3.1 or later to address the vulnerabilities.
VulnCheckMore articles in this cluster (3)
Common questions
Which versions are affected?
Semantic MediaWiki versions 2.5.0 through 7.3.0 are affected by the vulnerabilities.
Is there any active exploitation?
No active exploitation has been reported for these vulnerabilities at this time.
What should I do if I'm using an affected version?
Upgrade to Semantic MediaWiki version 7.3.1 or later to mitigate the vulnerabilities.
Continue Reading
PHP2Shell Vulnerabilities Exploited by AI-Driven Attackers Threat actors have exploited PHP2Shell vulnerabilities (CVE-2026-109618 and CVE-2026-109619) to target a government entity in Europe, gaining access to sensitive data within two hours of the initial breach. The attackers utilized AI tools for reconnaissance and post-exploitation activities, including accessing…