Thehackernews cPGuard Update Channel Compromised, Backdoor Installed on Linux Servers
Article Content
- •An attacker compromised cPGuard's update system, distributing a backdoor script.
- •The malicious script collected sensitive data from affected Linux servers.
- •Administrators must update to version 5.88.25 and reset all exposed credentials.
On November 2, 2026, an unidentified attacker compromised the update system of the cPGuard security tool, distributing a malicious script that installed a backdoor on customer Linux servers. The script collected sensitive data, including password hashes and configuration files, and uploaded it to OPSSHIELD's licensing server. The affected versions of cPGuard are 5.88.12 through 5.88.19, and the company has since released version 5.88.25 to remove the backdoor. OPSSHIELD is investigating how the attacker gained access to its credentials and how many servers were impacted. Administrators are advised to update their servers immediately and reset all passwords and credentials that may have been exposed. The attack was detected within 12 hours of the malicious script's distribution, and the company has secured its infrastructure to prevent further exploitation.
Ask AI about this cluster
Answers cite the sources they use
Timeline
More articles in this cluster (4)
Following this threat?
Track Opsshield in your own feed — you're alerted when they show up in new reporting, leak sites or exploitation.
Free account · no card needed
Common questions
Which versions of cPGuard are affected?
What immediate actions should I take?
How was the breach detected?
Continue Reading
Critical Zero-Day Exploited in BeyondTrust Remote Support by China-linked Group A critical vulnerability in BeyondTrust Remote Support, tracked as CVE-2026-102764 with a CVSS score of 9.3, has been exploited by the China-linked espionage group Armory Castle since August 29, 2026. This flaw allows unauthenticated remote attackers to perform file operations, gaining root control and access to…
Critical RCE Vulnerability in Prefab UI Disclosed A critical remote code execution vulnerability, CVE-2026-120338, was disclosed on November 1, 2026, affecting Prefab UI's Generative UI sandbox. The flaw allows attackers to execute arbitrary Python code by exploiting Deno's permissions, enabling file read/write access on the host server. This vulnerability affects…