Daily.Dev GitLab Issues Emergency Patch for Critical RCE Vulnerability
Article Content
- •CVE-2026-97229 is a critical RCE vulnerability with a CVSS score of 10.0.
- •The flaw allows unauthenticated attackers to execute arbitrary code via crafted regex in CI/CD configurations.
- •Self-managed GitLab installations must upgrade to versions 19.4.2, 19.3.4, or 19.2.8 immediately.
GitLab has released emergency patches for a critical remote code execution vulnerability, CVE-2026-97229, affecting its Community and Enterprise Editions. This flaw, stemming from an integer overflow in the CI/CD regular expression compiler, allows unauthenticated attackers to execute arbitrary code via specially crafted regular expressions in pipeline configurations. The vulnerability carries a CVSS score of 10.0 and affects all versions from 19.2 prior to 19.2.8, 19.3 prior to 19.3.4, and 19.4 prior to 19.4.2. GitLab has confirmed that GitLab.com is already patched, while self-managed installations must upgrade immediately. The flaw was reported by a researcher known as 'joaxcar' through GitLab's HackerOne bug bounty program. This incident highlights a growing trend of critical vulnerabilities in GitLab's software, with multiple serious flaws disclosed in 2026.
Ask AI about this cluster
Answers cite the sources they use
Timeline
More articles in this cluster (101)
Following this threat?
Track Goldman Sachs and CVE-2026-0723 in your own feed — you're alerted when they show up in new reporting, leak sites or exploitation.
Free account · no card needed
Common questions
Which versions are affected?
Is this vulnerability being exploited?
What should I do to protect my systems?
Continue Reading
GitLab CVE-2026-110264: Critical RCE Flaw Patched GitLab released emergency patches for CVE-2026-110264 on October 21, 2026, addressing a critical remote code execution vulnerability in its regular expression compiler. The flaw, which has a CVSS score of 10.0, allows unauthenticated attackers to execute arbitrary code on self-managed servers. This vulnerability…
Critical Zero-Day Exploited in BeyondTrust Remote Support by China-linked Group A critical vulnerability in BeyondTrust Remote Support, tracked as CVE-2026-102764 with a CVSS score of 9.3, has been exploited by the China-linked espionage group Armory Castle since August 29, 2026. This flaw allows unauthenticated remote attackers to perform file operations, gaining root control and access to…