Integer Overflow Vulnerability in Qt XML Parsing (CVE-2026-100140)
Article Content
- •CVE-2026-100140 affects multiple Qt versions due to an integer overflow vulnerability.
- •Exploitation can lead to memory corruption and application crashes, causing Denial of Service.
- •Patches are available, and users are urged to upgrade to secure versions.
An integer overflow vulnerability (CVE-2026-100140) has been identified in the XML parsing functionality of Qt5Compat, affecting versions 6.0.0 through 6.8.9, 6.9.0 through 6.11.2, and 6.12.0. An unauthenticated attacker can exploit this flaw by providing specially crafted XML input, potentially leading to memory corruption and application crashes, resulting in a Denial of Service (DoS). Currently, there is no evidence of or public proof-of-concept code. Patches are available for affected versions, and users are advised to upgrade to Qt 6.8.10, 6.11.3, or 6.12.1 or later. Input validation and sanitization for XML data from untrusted sources is also recommended. The CVSS score assigned to this vulnerability is 1.9, indicating a low severity level.
Ask AI about this cluster
Answers cite the sources they use
Timeline
More articles in this cluster (4)
Following this threat?
Track CVE-2026-100140 in your own feed — you're alerted when they show up in new reporting, leak sites or exploitation.
Free account · no card needed
Common questions
Which versions of Qt are affected?
Is there evidence of active exploitation?
What should I do to protect my applications?
Continue Reading
Critical RCE Vulnerability in Prefab UI Disclosed A critical remote code execution vulnerability, CVE-2026-120338, was disclosed on November 1, 2026, affecting Prefab UI's Generative UI sandbox. The flaw allows attackers to execute arbitrary Python code by exploiting Deno's permissions, enabling file read/write access on the host server. This vulnerability affects…
China-Linked Hackers Exploit PHP2Shell Vulnerabilities to Breach U.S. Government Systems On October 21, 2026, the PHP development team released patches for two critical vulnerabilities in PHP, known as PHP2Shell (CVE-2026-109618 and CVE-2026-109619), which allow unauthenticated remote code execution. These vulnerabilities were actively exploited by a suspected China-linked threat actor who compromised 25…