Remote Code Execution Vulnerability in Amazon Redshift JDBC Driver
Article Content
- •CVE-2026-119084 allows remote code execution in Amazon Redshift JDBC Driver < 2.3.0.
- •Attackers can exploit this flaw by manipulating JDBC connection URLs or AWS credentials.
- •Amazon recommends upgrading to version 2.3.0 to mitigate the vulnerability.
A vulnerability, CVE-2026-119084, was disclosed on November 3, 2026, affecting Amazon Redshift JDBC Driver versions prior to 2.3.0. The flaw allows an attacker to execute arbitrary code by manipulating JDBC connection URL parameters or AWS credentials profile fields. This vulnerability could be exploited if an actor can influence these parameters, leading to potential code execution in the application's context. Amazon has released version 2.3.0 to address this issue and recommends immediate upgrades. Users unable to upgrade should ensure that their applications do not construct JDBC connection URLs from untrusted input. The vulnerability has a CVSS score of 8.1, indicating a high severity level. Security researchers involved in the disclosure process include 4ra1n, pyn3rd, and unam4.
Ask AI about this cluster
Answers cite the sources they use
Timeline
More articles in this cluster (5)
Following this threat?
Track CVE-2026-119084 in your own feed — you're alerted when they show up in new reporting, leak sites or exploitation.
Free account · no card needed
Common questions
Which versions are affected?
Is there a patch available?
What should I do if I can't upgrade immediately?
Continue Reading
Critical Zero-Day Exploited in BeyondTrust Remote Support by China-linked Group A critical vulnerability in BeyondTrust Remote Support, tracked as CVE-2026-102764 with a CVSS score of 9.3, has been exploited by the China-linked espionage group Armory Castle since August 29, 2026. This flaw allows unauthenticated remote attackers to perform file operations, gaining root control and access to…
Critical RCE Vulnerability in Prefab UI Disclosed A critical remote code execution vulnerability, CVE-2026-120338, was disclosed on November 1, 2026, affecting Prefab UI's Generative UI sandbox. The flaw allows attackers to execute arbitrary Python code by exploiting Deno's permissions, enabling file read/write access on the host server. This vulnerability affects…